<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://drizzleandhurricanebooks.com/xmlrpc.php">

<title>20 book series I want to finish reading&#8230;. or not</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Lato:r:latin,latin-ext","Karla:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s0.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active button, .wf-active html, .wf-active input, .wf-active select, .wf-active textarea, .wf-active body{font-family:"Karla",sans-serif}.wf-active blockquote cite, .wf-active blockquote small{font-family:"Karla",sans-serif}.wf-active th{font-family:"Karla",sans-serif}.wf-active .comment-navigation a, .wf-active .nav-links .nav-next, .wf-active .nav-links .nav-previous, .wf-active .st-button, .wf-active a.comment-reply-link, .wf-active a.more-link, .wf-active button, .wf-active input[type="button"], .wf-active input[type="reset"], .wf-active input[type="submit"]{font-family:"Karla",sans-serif}.wf-active .jetpack_subscription_widget #subscribe-email input, .wf-active .widget_blog_subscription input[type="text"], .wf-active input[type="email"], .wf-active input[type="password"], .wf-active input[type="search"], .wf-active input[type="text"], .wf-active input[type="url"], .wf-active textarea{font-family:"Karla",sans-serif}.wf-active .site-description{font-family:"Karla",sans-serif}.wf-active .main-navigation{font-family:"Karla",sans-serif}.wf-active .image-navigation .meta-nav{font-family:"Karla",sans-serif}.wf-active .page-links{font-family:"Karla",sans-serif}.wf-active .page-links a{font-family:"Karla",sans-serif}.wf-active .comment-author .fn{font-family:"Karla",sans-serif}.wf-active .widget_recent_entries > ul > li a{font-family:"Karla",sans-serif}.wf-active .widget_recent_comments > ul > li .comment-author-link, .wf-active .widget_recent_comments > ul > li .comment-author-link a{font-family:"Karla",sans-serif}.wf-active .widget_recent_comments > ul > li a{font-family:"Karla",sans-serif}.wf-active .widgets-list-layout-links > .bump-view{font-family:"Karla",sans-serif}.wf-active #main #infinite-handle span{font-family:"Karla",sans-serif}.wf-active .widget_text blockquote cite{font-family:"Karla",sans-serif}.wf-active #full-footer .null-instagram-feed p.clear a{font-family:"Karla",sans-serif}.wf-active .site-info p.info{font-family:"Karla",sans-serif}.wf-active #page .social-footer .jetpack-social-navigation ul li a span{font-family:"Karla",sans-serif}.wf-active h1, .wf-active h2, .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6{font-family:"Lato",sans-serif;font-weight:400;font-style:normal}.wf-active h1{font-style:normal;font-weight:400}.wf-active h2{font-style:normal;font-weight:400}.wf-active h3{font-style:normal;font-weight:400}.wf-active h4{font-style:normal;font-weight:400}.wf-active h5{font-style:normal;font-weight:400}.wf-active h6{font-style:normal;font-weight:400}.wf-active .site-title{font-style:normal;font-weight:400}.wf-active h1.entry-title{font-style:normal;font-weight:400}.wf-active .single h1.entry-title{font-style:normal;font-weight:400}.wf-active #page .comment-reply-title, .wf-active #page .comments-title, .wf-active #page .no-comments{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active .widget-title{font-weight:400;font-style:normal}.wf-active #main div.sharedaddy h3.sd-title{font-weight:400;font-style:normal}.wf-active .author-description h3{font-style:normal;font-weight:400}.wf-active #main div#jp-relatedposts div.jp-relatedposts-items .jp-relatedposts-post .jp-relatedposts-post-title a{font-weight:400;font-family:"Lato",sans-serif;font-style:normal}.wf-active #main div#jp-relatedposts h3.jp-relatedposts-headline{font-family:"Lato",sans-serif;font-style:normal;font-weight:400}.wf-active #page .jetpack-display-remote-posts h4{font-weight:400;font-family:"Lato",sans-serif;font-style:normal}.wf-active .archive-title, .wf-active .page-title{font-style:normal;font-weight:400}.wf-active .site-title{font-style:normal;font-weight:400}.wf-active h1.entry-title{font-style:normal;font-weight:400}.wf-active .single h1.entry-title{font-style:normal;font-weight:400}.wf-active #page .comment-reply-title, .wf-active #page .comments-title, .wf-active #page .no-comments{font-style:normal;font-weight:400}.wf-active .author-description h3, .wf-active .widget-title{font-style:normal;font-weight:400}</style>

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//drizzleandhurricanebooks.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//wordpress.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="https://drizzleandhurricanebooks.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="https://drizzleandhurricanebooks.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; 20 book series I want to finish reading&#8230;. or&nbsp;not Comments Feed" href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s0.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1582709031h&ver=5.4-beta1-47310"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJy1k9tugzAMhl9oIdBQaC+mPUsAw9zmgBKniLdfIN2p29hUaTcI2/9n/4oTPo2stYbAENeBjSoMaDyfxtZq5jUqmG+irPX+gX+POVCSoGOj9XQTbWEKz+D5CWiU7Zmt0Rf5q3YIMWzADbHigNeZyHLeBFQdb5Rd8cZJN3NPs4I/tFmp9+lwibIoD4Y6O5l72yg520BscNjd28JJQjP4e3FCDQoN/ML3QSnmkYBBh8vA61Z4JfZ1dairsmn7fneoZd8WILq8hArKvhYSynx3FNVy7EPacbLAO/TELwjTj0NbezVbZLs8K9h6wRKXClkyve71H60n1yrO/Wj9Nrt1dZdLGPN6lLQodHQiQYGOsi0svaimGR14z+JXY9CMniO4+VIitbROb4RH4edMQpEbSxhp//azFJ70Y7E/5AdxFGJ/egHRHHdf?cssminify=yes' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify {
	text-align:justify;
}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='rosalie-webfont-css'  href='https://fonts.googleapis.com/css?family=Lora%3A400%2C700%2C400italic%2C700italic%7CMontserrat%3A400%2C700&#038;subset=latin%2Clatin-ext' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s0.wp.com/_static/??-eJx9jcEOAiEMRH9IrJKs2YvxWxBrraFAaMnGvxdPrgf39iYzLwNLdbFkw2xgDxRUqA2Fu0ArGhIjqL0S7qPqDlZj6a6mTpwVCDM2HsUf3HIXvhGawmAL1IJ8afuyuFRiMC75J7h7Cty21IbXVGggwVit4ke6yPk4eX+YT36an28UOWtK?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s2.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s0.wp.com/_static/??-eJx9jt1uwyAMhV9ozGkhJL2Y9iwOGEJHIIodVXv7MalVW1XqlX2k7/zAZVWuFqEisOxqzXtMhQGdpFom3O7fp2P+gAf8xoY9Z8VJSJFPkkq8poDV/WDHwZrJhXAcBwzuQNp3hiyZMGgk0x1P2kLMdcKWIb+ZGFhQkoMpY/l5KX3YuFYWFTKmDXjGrRXf7jsXV5daV66xPosXk8y0tDmzue57l3pJPpIwxFr9RugZGnxX/9bv5evQj92oT1r35z+GoohK?cssminify=yes' type='text/css' media='all' />
<style id='jetpack-global-styles-frontend-style-inline-css'>
:root { --font-headings: unset; --font-base: unset; --font-headings-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif; --font-base-default: -apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue",sans-serif;}
</style>
<script>
var related_posts_js_options = {"post_heading":"h4"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFj9EOwiAMRX9Ihntw0wfjtyCrpAgFKbjo1wuJPrgsmjRpbnpy762co0DSrkzA0ta5FUiP9+osb+QvQHg0SWXoPNIH1oEyUG5sDJw9MCsDK1cfzuhAFIZUAco15hKWnC8iumKQWCZwNWoSzXWhVty/H0G6I8x/MQs5Kn0VCRifrfPJH/vd2B+24zDs7QszQHB9'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://drizzleandhurricanebooks.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Review: The Stars We Steal, Alexa&nbsp;Donne' href='https://drizzleandhurricanebooks.com/2020/02/21/review-the-stars-we-steal-alexa-donne/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/" />
<link rel='shortlink' href='https://wp.me/p5pugy-3wB' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fdrizzleandhurricanebooks.com%2F2020%2F02%2F26%2F20-book-series-i-want-to-finish-reading-or-not%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fdrizzleandhurricanebooks.com%2F2020%2F02%2F26%2F20-book-series-i-want-to-finish-reading-or-not%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="20 book series I want to finish reading&#8230;. or not" />
<meta property="og:url" content="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/" />
<meta property="og:description" content="Hi friends! I have a confession to make: book series and I aren&#8217;t necessarily in the very best terms. I&#8217;m not sure if it&#8217;s because it&#8217;s easier to pick up a standalone than a…" />
<meta property="article:published_time" content="2020-02-26T13:00:39+00:00" />
<meta property="article:modified_time" content="2020-02-26T17:49:29+00:00" />
<meta property="og:image" content="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png" />
<meta property="og:image:width" content="750" />
<meta property="og:image:height" content="329" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@dh_books" />
<meta name="twitter:site" content="@dh_books" />
<meta name="twitter:text:title" content="20 book series I want to finish reading&#8230;. or&nbsp;not" />
<meta name="twitter:image" content="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/9a7bb0dd9e189b707244722c0b94bc8e?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/9a7bb0dd9e189b707244722c0b94bc8e?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/9a7bb0dd9e189b707244722c0b94bc8e?s=114" />
<link rel='openid.server' href='https://drizzleandhurricanebooks.com/?openidserver=1' />
<link rel='openid.delegate' href='https://drizzleandhurricanebooks.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://drizzleandhurricanebooks.com/osd.xml" title="" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="theme-color" content="#ffffff" />
		<style type="text/css">
			.recentcomments a {
				display: inline !important;
				padding: 0 !important;
				margin: 0 !important;
			}

			table.recentcommentsavatartop img.avatar, table.recentcommentsavatarend img.avatar {
				border: 0px;
				margin: 0;
			}

			table.recentcommentsavatartop a, table.recentcommentsavatarend a {
				border: 0px !important;
				background-color: transparent !important;
			}

			td.recentcommentsavatarend, td.recentcommentsavatartop {
				padding: 0px 0px 1px 0px;
				margin: 0px;
			}

			td.recentcommentstextend {
				border: none !important;
				padding: 0px 0px 2px 10px;
			}

			.rtl td.recentcommentstextend {
				padding: 0px 10px 2px 0px;
			}

			td.recentcommentstexttop {
				border: none;
				padding: 0px 0px 0px 10px;
			}

			.rtl td.recentcommentstexttop {
				padding: 0px 10px 0px 0px;
			}
		</style>
		<meta name="application-name" content="WordPress.com" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Drizzle &amp; Hurricane Books - A hurricane of ya books, a drop of blogging and a whole lot of feelings" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://drizzleandhurricanebooks.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/9a7bb0dd9e189b707244722c0b94bc8e?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="Hi friends! I have a confession to make: book series and I aren&#039;t necessarily in the very best terms. I&#039;m not sure if it&#039;s because it&#039;s easier to pick up a standalone than a book series, or because, no matter how GOOD a book might be, I&#039;m slightly terrified that their sequels won&#039;t live up&hellip;" />
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="amphtml" href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/amp/"><style type="text/css" id="custom-colors-css">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</style>
</head>

<body class="post-template-default single single-post postid-13553 single-format-standard custom-background customizer-styles-applied rosalie-fixed-menu has-site-logo highlander-enabled highlander-light">
	<div id="page" class="site">

		<header id="masthead" class="site-header" role="banner">
			<div id="navbar" class="navbar">
				<div class="container-fluid">
					<div class="row">
											<div class="col-xs-11 col-xs-push-1 col-lg-3 col-lg-push-9 textright-xs social-rtl">
													</div><!-- .col-xs-10 -->
						<div class="col-lg-9 col-lg-pull-3 menu-rtl">
							<div class="menu-toggle"><i></i><span class="screen-reader-text">Primary Menu</span></div>
							<nav id="site-navigation" class="navigation main-navigation" role="navigation">
								<div class="menu-menu-haut-container"><ul id="menu-menu-haut" class="nav-menu"><li id="menu-item-57" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57"><a href="https://drizzleandhurricanebooks.wordpress.com/">Home</a></li>
<li id="menu-item-6573" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-6573"><a href="https://drizzleandhurricanebooks.com/#">About</a>
<ul class="sub-menu">
	<li id="menu-item-6120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6120"><a href="https://drizzleandhurricanebooks.com/about/">About the blogger</a></li>
	<li id="menu-item-6519" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6519"><a href="https://drizzleandhurricanebooks.com/about/work-with-me/">Work with me &amp; Review Policies</a></li>
	<li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59"><a href="https://drizzleandhurricanebooks.com/about/contact/">Contact me</a></li>
	<li id="menu-item-8494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8494"><a href="https://drizzleandhurricanebooks.com/about/disclaimers/">Disclaimers</a></li>
</ul>
</li>
<li id="menu-item-3237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3237"><a href="https://drizzleandhurricanebooks.com/category/books-by-genre/">Books &amp; Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-3238" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3238"><a href="https://drizzleandhurricanebooks.com/category/books-by-genre/">Book reviews</a></li>
	<li id="menu-item-3231" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3231"><a href="https://drizzleandhurricanebooks.com/category/book-discussions/">Book discussions</a></li>
	<li id="menu-item-3232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3232"><a href="https://drizzleandhurricanebooks.com/category/features/">Features</a>
	<ul class="sub-menu">
		<li id="menu-item-10761" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10761"><a href="https://drizzleandhurricanebooks.com/category/features/author-features/">Author Features</a></li>
	</ul>
</li>
	<li id="menu-item-1630" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1630"><a href="https://drizzleandhurricanebooks.com/rating-system/">Rating System</a></li>
	<li id="menu-item-3233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3233"><a href="https://drizzleandhurricanebooks.com/reviews-by-title/">Review Index</a></li>
</ul>
</li>
<li id="menu-item-6517" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6517"><a href="https://drizzleandhurricanebooks.com/category/book-blogging/">Book blogging</a></li>
<li id="menu-item-3991" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3991"><a href="https://drizzleandhurricanebooks.com/category/nyxs-corner/">Nyx&#8217;s Corner</a></li>
<li id="menu-item-3234" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3234"><a href="https://drizzleandhurricanebooks.com/category/a-ticket-to-anywhere/">Travel</a></li>
<li id="menu-item-3264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3264"><a href="https://drizzleandhurricanebooks.com/category/writing-2/">Writing</a></li>
</ul></div>							</nav><!-- #site-navigation -->
						</div><!-- .col-xs-12 -->
										</div><!-- .row -->
				</div><!-- .container -->
			</div><!-- #navbar -->
		</header><!-- #masthead -->

			<section class="image-header textcenter-xs">
						<a href="https://drizzleandhurricanebooks.com/" class="site-logo-link" rel="home" itemprop="url"><img width="1000" height="350" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png?w=1000" class="site-logo attachment-rosalie-logo" alt="" data-size="rosalie-logo" itemprop="logo" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png 1000w, https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png?w=150 150w, https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png?w=300 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png?w=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="10007" data-permalink="https://drizzleandhurricanebooks.com/drizzle-and-hurrican-books-tornado/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png" data-orig-size="1000,350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="drizzle and hurrican books tornado" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurrican-books-tornado.png?w=750" /></a>						<h1 class="site-title"><a href="https://drizzleandhurricanebooks.com/" rel="home"></a></h1>
			<p class="site-description">Drizzle &amp; Hurricane Books &#8211; A hurricane of ya books, a drop of blogging and a whole lot of feelings</p>
						<div class="container">
				<div class="col-xs-12 textcenter-xs">
									</div><!-- .col-xs-10 -->
			</div><!-- .container -->
					</section><!-- .image-header -->
	
	

<section id="content" class="site-content">
	<div class="container">
		<div class="row">
						<div id="primary" class="content-area col-lg-8">
							<main id="main" class="site-main" role="main">

					
						
<article id="post-13553" class="post-13553 post type-post status-publish format-standard has-post-thumbnail hentry category-book-discussions tag-book-bloggers tag-book-discussion tag-book-list tag-book-recommendations tag-book-series tag-contemporary tag-fantasy tag-ya-books tag-ya-contemporary tag-ya-fantasy">
	<header class="entry-header">
		<h1 class="entry-title textleft-xs">20 book series I want to finish reading&#8230;. or&nbsp;not</h1>		<div class="entry-meta textleft-xs">
			<span class="author vcard"><i class="genericon genericon-edit"></i><a class="url fn n" href="https://drizzleandhurricanebooks.com/author/drizzleandhurricanebooks/" title="View all posts by Marie" rel="author">Marie</a></span><span class="categories-links-index"><i class="genericon genericon-category"></i><a href="https://drizzleandhurricanebooks.com/category/book-discussions/" rel="category tag">Book discussions</a></span><span class="tags-links"><i class="genericon genericon-tag"></i><a href="https://drizzleandhurricanebooks.com/tag/book-bloggers/" rel="tag">book bloggers</a>, <a href="https://drizzleandhurricanebooks.com/tag/book-discussion/" rel="tag">book discussion</a>, <a href="https://drizzleandhurricanebooks.com/tag/book-list/" rel="tag">book list</a>, <a href="https://drizzleandhurricanebooks.com/tag/book-recommendations/" rel="tag">book recommendations</a>, <a href="https://drizzleandhurricanebooks.com/tag/book-series/" rel="tag">book series</a>, <a href="https://drizzleandhurricanebooks.com/tag/contemporary/" rel="tag">contemporary</a>, <a href="https://drizzleandhurricanebooks.com/tag/fantasy/" rel="tag">fantasy</a>, <a href="https://drizzleandhurricanebooks.com/tag/ya-books/" rel="tag">ya books</a>, <a href="https://drizzleandhurricanebooks.com/tag/ya-contemporary/" rel="tag">ya contemporary</a>, <a href="https://drizzleandhurricanebooks.com/tag/ya-fantasy/" rel="tag">ya fantasy</a></span><span class="comments-link"><i class="genericon genericon-chat"></i><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comments">20 Comments</a></span>		</div><!-- .entry-meta -->
				<div class="entry-thumbnail">
			<img width="750" height="329" src="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=750" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=750 750w, https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=150 150w, https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=300 300w, https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=768 768w, https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=1024 1024w, https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png 1140w" sizes="(max-width: 750px) 100vw, 750px" data-attachment-id="13558" data-permalink="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/20-book-series-i-want-to-finish-reading-or-not/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png" data-orig-size="1140,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="20 book series I want to finish reading&#8230;. or not" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/20-book-series-i-want-to-finish-reading....-or-not.png?w=750" />		</div><!-- .entry-thumbnail -->
			</header><!-- .entry-header -->

	<div class="entry-content">
		<p><span style="font-size:14pt;">Hi friends! </span>I have a confession to make: <span style="font-size:14pt;">book series</span> and I aren&#8217;t necessarily in the very best terms. I&#8217;m not sure if it&#8217;s because it&#8217;s easier to pick up a standalone than a book series, or because, no matter how GOOD a book might be, I&#8217;m slightly terrified that their <strong>sequels won&#8217;t live up to the hype</strong>.</p>
<p>All of this to say: I <strong>have A LOT of book series on my TBR</strong>.</p>
<p><img data-attachment-id="13569" data-permalink="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/book-series-3/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/book-series.gif" data-orig-size="957,537" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="book series" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/book-series.gif?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/book-series.gif?w=750" class="aligncenter size-medium wp-image-13569" src="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/book-series.gif?w=300&#038;h=168" alt="" width="300" height="168" /></p>
<p>Some I haven&#8217;t even started just yet, but <strong>really want to</strong>. Some others I have started, but haven&#8217;t gotten around to completing just yet. Some others I&#8217;m <span style="font-size:14pt;">waiting impatiently to release</span>&#8230; and will most likely read it a gazillion years later, because, well. Aerm.</p>
<p>There are some other series I&#8217;ve thought about <strong>giving up on</strong>.</p>
<p>Today, my blog post is all about this. The <span style="font-size:14pt;">series I want to continue</span>, will continue, commit myself to the task because these books are GOOD and deserve to be finished. I&#8217;ll also mention the series I&#8217;m <strong>thinking of giving up on</strong>, because, well, can&#8217;t do it all and these don&#8217;t appeal to me anymore. Sometimes, we need to be strict. Also, please don&#8217;t judge me.</p>
<p><em><img data-attachment-id="13468" data-permalink="https://drizzleandhurricanebooks.com/?attachment_id=13468" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/post-divider-3.png" data-orig-size="550,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="post divider 3" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/post-divider-3.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/post-divider-3.png?w=550" class="aligncenter size-medium wp-image-13468" src="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/post-divider-3.png?w=300&#038;h=109" alt="" width="300" height="109" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2020/02/post-divider-3.png?w=300&amp;h=109 300w, https://drizzleandhurricanebooks.files.wordpress.com/2020/02/post-divider-3.png?w=150&amp;h=55 150w, https://drizzleandhurricanebooks.files.wordpress.com/2020/02/post-divider-3.png 550w" sizes="(max-width: 300px) 100vw, 300px" /></em></p>
<h1>📚 Book series on my TBR I want to finish &#8211; the already released ones</h1>
<p>This category will contain all the series that are completed&#8230; but that <em>I</em> just haven&#8217;t completed just yet.</p>
<h2>The Reader, Traci Chee</h2>
<p><img data-attachment-id="2949" data-permalink="https://drizzleandhurricanebooks.com/2016/02/23/top-ten-tuesday-45-top-ten-books-i-want-to-read-that-are-out-of-my-comfort-zone/the-reader/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg" data-orig-size="313,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="the reader" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg?w=313" class="alignleft wp-image-2949" src="https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2016/02/the-reader.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" /><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> I&#8217;ve mentioned this series a whole damn lot lately, but&#8230; I really love it. I loved the first two books very much, it&#8217;s <strong>unique, original, addictive</strong> and I can&#8217;t wait to see how it all ends. READ this awesome series, friends. Please.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2019/02/15/bullet-point-review-the-reader-traci-chee/">📖 read my full review of the reader</a></p>
<h2><img data-attachment-id="9113" data-permalink="https://drizzleandhurricanebooks.com/2018/09/05/10-books-im-excited-to-read-soon/am-i-normal-yet/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg" data-orig-size="308,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="am i normal yet" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg?w=195" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg?w=308" class="alignright wp-image-9113" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg?w=130&#038;h=200" alt="" width="130" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg?w=130&amp;h=200 130w, https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg?w=260&amp;h=400 260w, https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg?w=97&amp;h=150 97w, https://drizzleandhurricanebooks.files.wordpress.com/2018/08/am-i-normal-yet.jpg?w=195&amp;h=300 195w" sizes="(max-width: 130px) 100vw, 130px" />Am I Normal Yet?, Holly Bourne</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span> </strong>YAY a contemporary series on this list! I loved <em>Am I Normal Yet?</em> so much and I&#8217;ve been meaning to read the next books in the series for quite some time, now. I love <strong>these characters, the talk about mental health, this group of friends</strong>. Definitely recommending it.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2018/10/26/mini-reviews-odd-one-out-am-i-normal-yet/">📖 read my full review of am i normal yet?</a></p>
<h2><img data-attachment-id="8647" data-permalink="https://drizzleandhurricanebooks.com/2018/06/22/mini-reviews-restore-me-this-mortal-coil/this-mortal-coil/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg" data-orig-size="309,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="this mortal coil" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg?w=195" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg?w=309" class="alignleft wp-image-8647" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg?w=130&#038;h=200" alt="" width="130" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg?w=130&amp;h=200 130w, https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg?w=260&amp;h=400 260w, https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg?w=98&amp;h=150 98w, https://drizzleandhurricanebooks.files.wordpress.com/2018/06/this-mortal-coil.jpg?w=195&amp;h=300 195w" sizes="(max-width: 130px) 100vw, 130px" />This Mortal Coil, Emily Suvada</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> I was kind of obsessed with <em>This Mortal Coil</em> when I first read it, which is&#8230; well, surprising given that I don&#8217;t read a lot of sci-fi. But everything about this, the <strong>twists and turns, the characters, the world, made me SCREAM</strong> and&#8230; I don&#8217;t know why I haven&#8217;t picked up these next books just yet.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2018/06/22/mini-reviews-restore-me-this-mortal-coil/">📖 read my full review of this mortal coil</a></p>
<h2><img data-attachment-id="8455" data-permalink="https://drizzleandhurricanebooks.com/2018/06/03/10-books-that-would-make-awesome-movies/the-belles-4/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg" data-orig-size="314,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Belles" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg?w=314" class="alignright wp-image-8455" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2018/05/the-belles.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />The Belles, Dhonielle Clayton</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong>  I really enjoyed the first book in <em>The Belles</em> series, despite its problematic elements and I&#8217;m still <strong>curious enough about the world</strong> to want to know what happens in the second book of this duology!</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2018/03/16/bullet-point-review-the-belles-dhonielle-clayton/">📖 read my full review of the belles</a></p>
<h2><img data-attachment-id="7646" data-permalink="https://drizzleandhurricanebooks.com/2017/12/22/review-this-savage-song-victoria-schwab/this-savage-song-2/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg" data-orig-size="315,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="this savage song" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg?w=199" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg?w=315" class="alignleft wp-image-7646" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg?w=133&#038;h=200" alt="" width="133" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg?w=133&amp;h=200 133w, https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg?w=266&amp;h=400 266w, https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2017/12/this-savage-song1.jpg?w=199&amp;h=300 199w" sizes="(max-width: 133px) 100vw, 133px" />This Savage Song, V. Schwab</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎 </span></strong><em>This Savage Song</em>&#8216;s second book, <em>Our Dark Duet</em>, has been on my TBR forever and I need to read it&#8230; soon. But I <strong>got spoiled and know how it ends so I&#8217;m a tiny bit frustrated</strong> about it. Still, I&#8217;ll read it someday, I swear I will.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2017/12/22/review-this-savage-song-victoria-schwab/">📖 read my full review of this savage song</a></p>
<p>&nbsp;</p>
<h2><img data-attachment-id="7342" data-permalink="https://drizzleandhurricanebooks.com/2017/10/29/monthly-wrap-up-october-2017/legend/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg" data-orig-size="314,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="legend" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg?w=314" class="alignright wp-image-7342" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/legend.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />Legend, Marie Lu</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> I&#8217;ve read <em>Legend</em> a&#8230; long time ago and I remember enjoying it and being really curious about what would happen next. Then, I don&#8217;t know, other books came on and I <strong>didn&#8217;t make <em>Legend</em> a priority anymore</strong>. But I really want to. I know some friends who really love this series and I want to love it too!<em><br />
</em></p>
<p>&nbsp;</p>
<h2><img data-attachment-id="7816" data-permalink="https://drizzleandhurricanebooks.com/2018/01/21/books-i-cant-believe-i-havent-read-yet-and-neither-will-you/star-touched-queen/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg" data-orig-size="313,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="star touched queen" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg?w=313" class="alignleft wp-image-7816" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2018/01/star-touched-queen.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />The Star-Touched Queen, Roshani Chokshi</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> I really enjoyed this first book, <strong>despite its confusing moments</strong>, and I&#8217;ve heard great things about the second book in this duology, <em>A Crown of Wishes</em>. I&#8217;ve heard it&#8217;s even better than this first book, so I have to be curious!</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2018/08/24/bullet-point-review-the-star-touched-queen-roshani-chokshi/">📖 read my full review of the star touched queen</a></p>
<p><img data-attachment-id="10537" data-permalink="https://drizzleandhurricanebooks.com/about/disclaimers/post-divider-2/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png" data-orig-size="2000,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="post divider 2" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=750" class="aligncenter size-medium wp-image-10537" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=300&#038;h=45" alt="" width="300" height="45" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=300&amp;h=45 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=600&amp;h=90 600w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=150&amp;h=23 150w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<h1>📚 Book series I want to finish reading &#8211; the uncompleted ones</h1>
<p>This category contains series that are currently in the works (as of February, 2020).</p>
<h2><img data-attachment-id="8797" data-permalink="https://drizzleandhurricanebooks.com/2018/07/11/are-we-too-into-new-releases/we-set-the-dark-on-fire/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg" data-orig-size="317,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="we set the dark on fire" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg?w=200" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg?w=317" class="alignright wp-image-8797" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg?w=133&#038;h=200" alt="" width="133" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg?w=133&amp;h=200 133w, https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg?w=266&amp;h=400 266w, https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg?w=100&amp;h=150 100w, https://drizzleandhurricanebooks.files.wordpress.com/2018/07/we-set-the-dark-on-fire.jpg?w=200&amp;h=300 200w" sizes="(max-width: 133px) 100vw, 133px" />We Set The Dark On Fire, Tehlor Kay Mejia</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> I AM SCREAMING OKAY this book this book THIS BOOK made me fall in love and I am SO PUMPED for my preorder copy to arrive and to read it right away. It&#8217;s a <strong>stunningly written story, with great badass main characters</strong> and I can&#8217;t wait to know what happens next.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2019/05/10/bullet-point-review-we-set-the-dark-on-fire-tehlor-kay-meija/">📖 read my full review of we set the dark on fire</a></p>
<h2><img data-attachment-id="9826" data-permalink="https://drizzleandhurricanebooks.com/2018/12/16/my-2019-most-anticipated-reads-the-ya-fantasy-sci-fi-edition/the-gilded-wolves/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg" data-orig-size="313,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="the gilded wolves" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg?w=313" class="alignleft wp-image-9826" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2018/12/the-gilded-wolves.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />The Gilded Wolves, Roshani Chokshi</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> I&#8217;m really excited for this sequel to be released as well! I really enjoyed <em>The Gilded Wolves</em>, its <strong>world and its adventures and ESPECIALLY the cast of characters</strong> and I can&#8217;t wait to be back with them!</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2019/01/18/review-the-gilded-wolves-roshani-chokshi/">📖 read my full review of The Gilded wolves</a></p>
<h2><img data-attachment-id="8655" data-permalink="https://drizzleandhurricanebooks.com/2018/06/20/best-reads-of-2018-so-far-and-other-books-were-freaking-out-about/impostors/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg" data-orig-size="314,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="impostors" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg?w=314" class="alignright wp-image-8655" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2018/06/impostors.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />Impostors, Scott Westerfeld</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> I love the <em>Uglies</em> series, I really <strong>liked this first book set in the same world</strong> and I&#8217;m most definitely going to be reading every upcoming book as well. Once obsessed, always obsessed, okay.</p>
<p>&nbsp;</p>
<h2><img data-attachment-id="8359" data-permalink="https://drizzleandhurricanebooks.com/2018/05/06/top-10-favorite-book-covers/shatter-me-3/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg" data-orig-size="316,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Shatter Me" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg?w=200" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg?w=316" class="alignleft wp-image-8359" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg?w=133&#038;h=200" alt="" width="133" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg?w=133&amp;h=200 133w, https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg?w=266&amp;h=400 266w, https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg?w=100&amp;h=150 100w, https://drizzleandhurricanebooks.files.wordpress.com/2018/04/shatter-me.jpg?w=200&amp;h=300 200w" sizes="(max-width: 133px) 100vw, 133px" />Shatter Me, Tahereh Mafi</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> There was a time where I was obsessed with this series&#8230; now I think that somehow I have calmed down a little bit. I&#8217;m up to the <em>Restore Me</em> book, and if I&#8217;m curious to see what happens next, I&#8217;m also nervous because I&#8217;ve <strong>read so many mixed reviews</strong> about the next book&#8230;</p>
<p>&nbsp;</p>
<h2><img data-attachment-id="7284" data-permalink="https://drizzleandhurricanebooks.com/2017/10/20/review-an-ember-in-the-ashes-sabaa-tahir/an-ember-in-the-ashes/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg" data-orig-size="313,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="an ember in the ashes" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg?w=313" class="alignright wp-image-7284" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/an-ember-in-the-ashes.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />An Ember in the Ashes, Sabaa Tahir</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong> Another series I really, really enjoy, but haven&#8217;t completed just yet. For my defense: <strong>this series is like, INTENSE</strong>. I was almost out of breath after completing <em>A Torch Against the Night</em> and I really need to be ready to handle <em>A Reaper At The Gates</em>. That being said&#8230; I still can&#8217;t wait.</p>
<p>&nbsp;</p>
<h2><img data-attachment-id="7298" data-permalink="https://drizzleandhurricanebooks.com/2017/10/22/favorite-anticipated-books-and-some-other-bookish-questions-answered/the-becoming-of-noah-shaw/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg" data-orig-size="316,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="the becoming of noah shaw" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg?w=200" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg?w=316" class="alignleft wp-image-7298" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg?w=133&#038;h=200" alt="" width="133" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg?w=133&amp;h=200 133w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg?w=266&amp;h=400 266w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg?w=100&amp;h=150 100w, https://drizzleandhurricanebooks.files.wordpress.com/2017/10/the-becoming-of-noah-shaw.jpg?w=200&amp;h=300 200w" sizes="(max-width: 133px) 100vw, 133px" />The Becoming of Noah Shaw, Michelle Hodkin</h2>
<p><strong><span style="font-size:14pt;">Why I want to read it 🔎</span></strong>  I adore the Mara Dyer series so damn much&#8230;. but I felt underwhelmed by <em>The Becoming of Noah Shaw</em>, to be honest. It was lacking the intense feelings I got while reading Mara Dyer. Still, after thinking about this for a while, I feel like <strong>I still WANT to continue on with this series</strong> and know what happens next.</p>
<p>&nbsp;</p>
<p><img data-attachment-id="10537" data-permalink="https://drizzleandhurricanebooks.com/about/disclaimers/post-divider-2/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png" data-orig-size="2000,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="post divider 2" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=750" class="aligncenter size-medium wp-image-10537" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=300&#038;h=45" alt="" width="300" height="45" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=300&amp;h=45 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=600&amp;h=90 600w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/post-divider-2.png?w=150&amp;h=23 150w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<h1>📚 Book series on my TBR I&#8217;m not so sure I&#8217;ll finish&#8230; like, ever.</h1>
<h2><img data-attachment-id="9053" data-permalink="https://drizzleandhurricanebooks.com/2018/08/31/blog-tour-review-mirage-somaiya-daud-giveaway-us-only/mirage-cover/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg" data-orig-size="667,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mirage cover" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg?w=200" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg?w=667" class="alignright wp-image-9053" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg?w=133&#038;h=200" alt="" width="133" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg?w=133&amp;h=200 133w, https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg?w=266&amp;h=400 266w, https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg?w=100&amp;h=150 100w, https://drizzleandhurricanebooks.files.wordpress.com/2018/08/mirage-cover.jpg?w=200&amp;h=300 200w" sizes="(max-width: 133px) 100vw, 133px" />Mirage, Somaiya Daud</h2>
<p><strong>Why I don&#8217;t want to read it 🔎</strong> <em>Mirage</em> wasn&#8217;t a bad book, at all, in fact I remember enjoying the ride when I went on it, <strong>liking the world</strong> and especially the characters. That being said, right now, I <strong>don&#8217;t feel that deep <em>need</em> </strong>to continue with this series. Sorry, <em>Mirage</em>.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2018/08/31/blog-tour-review-mirage-somaiya-daud-giveaway-us-only/">📖 read my full review of mirage</a></p>
<p>&nbsp;</p>
<h2><img data-attachment-id="6445" data-permalink="https://drizzleandhurricanebooks.com/2017/05/31/monthly-wrap-up-may-2017/girl-from-everywhere/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg" data-orig-size="310,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="girl from everywhere" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg?w=196" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg?w=310" class="alignleft wp-image-6445" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg?w=131&#038;h=200" alt="" width="131" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg?w=131&amp;h=200 131w, https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg?w=262&amp;h=400 262w, https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg?w=98&amp;h=150 98w, https://drizzleandhurricanebooks.files.wordpress.com/2017/05/girl-from-everywhere.jpg?w=196&amp;h=300 196w" sizes="(max-width: 131px) 100vw, 131px" />The Girl From Everywhere, Heidi Heilig</h2>
<p><strong>Why I don&#8217;t want to read it 🔎</strong> I liked this first book, I really did, it was unique and original and I really appreciated that. But it&#8217;s been so many years since I&#8217;ve read it, I <strong>kind of lost any interest</strong> in going on with it.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2017/06/09/review-the-girl-from-everywhere-heidi-heilig/">📖 read my full review of the girl from everywhere</a></p>
<p>&nbsp;</p>
<h2><img data-attachment-id="8581" data-permalink="https://drizzleandhurricanebooks.com/2018/05/30/monthly-wrap-up-may-2018/children-of-blood-and-bone/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg" data-orig-size="313,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="children of blood and bone" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg?w=313" class="alignright wp-image-8581" src="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2018/05/children-of-blood-and-bone.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />Children of Blood and Bone, Tomi Adeyemi</h2>
<p><strong>Why I don&#8217;t want to read it 🔎</strong> Same here&#8230;. I liked this book when I read it, I understand the hype surrounding it, too. This is a book I&#8217;d definitely recommend, but <strong>getting on the sequel isn&#8217;t a priority</strong> at all.</p>
<p>&nbsp;</p>
<h2><img data-attachment-id="7639" data-permalink="https://drizzleandhurricanebooks.com/2017/12/20/2017-the-year-in-books-my-favorites-recommendations-and-more/daughter-of-smoke-and-bone/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg" data-orig-size="310,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="daughter of smoke and bone" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg?w=196" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg?w=310" class="alignleft wp-image-7639" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg?w=131&#038;h=200" alt="" width="131" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg?w=131&amp;h=200 131w, https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg?w=262&amp;h=400 262w, https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg?w=98&amp;h=150 98w, https://drizzleandhurricanebooks.files.wordpress.com/2017/12/daughter-of-smoke-and-bone.jpg?w=196&amp;h=300 196w" sizes="(max-width: 131px) 100vw, 131px" />Daughter of Smoke and Bone, Laini Taylor</h2>
<p><strong>Why I don&#8217;t want to read it 🔎</strong> <em>Daughter of Smoke and Bone</em> was an enjoyable read, if a little bit confusing at times. I liked the Prague setting and originality of it even if I wasn&#8217;t on board with everything. I feel like I&#8217;d be more interested in <strong>giving up on this series and picking up <em>Strange The Dreamer</em></strong>, by this author.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2018/01/05/mini-reviews-my-lady-jane-daughter-of-smoke-and-bone/">📖 read my full review of daughter of smoke and bone</a></p>
<h2><img data-attachment-id="6437" data-permalink="https://drizzleandhurricanebooks.com/2017/06/02/review-miss-peregrines-home-for-peculiar-children-ransom-riggs/miss-peregrine/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg" data-orig-size="307,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="miss peregrine" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg?w=194" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg?w=307" class="alignright wp-image-6437" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg?w=129&#038;h=200" alt="" width="129" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg?w=129&amp;h=200 129w, https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg?w=258&amp;h=400 258w, https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg?w=97&amp;h=150 97w, https://drizzleandhurricanebooks.files.wordpress.com/2017/05/miss-peregrine.jpg?w=194&amp;h=300 194w" sizes="(max-width: 129px) 100vw, 129px" />Miss Peregrine&#8217;s Home for Peculiar Children, Ransom Riggs</h2>
<p><strong>Why I don&#8217;t want to read it 🔎</strong> <em>Miss Peregrine</em> was&#8230; well, it was <strong>quite an average read</strong> for me, to be completely honest. I read my review from when I read it and it was quite okay, but if you ask me now&#8230; I don&#8217;t remember anything particular about this story, meaning that it <strong>wasn&#8217;t too remarkable</strong>, therefore&#8230; bye. Sorry.<em><br />
</em></p>
<p>&nbsp;</p>
<h2><img data-attachment-id="12674" data-permalink="https://drizzleandhurricanebooks.com/2019/12/01/monthly-wrap-up-november-2019/the-cruel-prince-2/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg" data-orig-size="317,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="the cruel prince" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg?w=200" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg?w=317" class="alignleft wp-image-12674" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg?w=133&#038;h=200" alt="" width="133" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg?w=133&amp;h=200 133w, https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg?w=266&amp;h=400 266w, https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg?w=100&amp;h=150 100w, https://drizzleandhurricanebooks.files.wordpress.com/2019/11/the-cruel-prince.jpg?w=200&amp;h=300 200w" sizes="(max-width: 133px) 100vw, 133px" />The Cruel Prince, Holly Black</h2>
<p><strong>Why I don&#8217;t want to read it 🔎</strong> I&#8230;. <strong>DO NOT SCREAM AT ME JUST YET</strong> okay. This category is here for series I&#8217;m <em>not sure</em> I&#8217;ll read, but this can, might change. I&#8217;ve heard mixed reviews about the sequels for this series and, if I liked <em>The Cruel Prince</em>, I wasn&#8217;t in love with it like everyone else. So, for now, <strong>the rest of the series is a maybe</strong>.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2019/12/27/review-the-cruel-prince-holly-black/">📖 read my full review of the cruel prince</a></p>
<h2><img data-attachment-id="6903" data-permalink="https://drizzleandhurricanebooks.com/2017/08/25/review-caraval-stephanie-garber/caraval-2/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg" data-orig-size="313,475" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="caraval" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg?w=198" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg?w=313" class="alignright wp-image-6903" src="https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg?w=132&#038;h=200" alt="" width="132" height="200" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg?w=132&amp;h=200 132w, https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg?w=264&amp;h=400 264w, https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg?w=99&amp;h=150 99w, https://drizzleandhurricanebooks.files.wordpress.com/2017/07/caraval1.jpg?w=198&amp;h=300 198w" sizes="(max-width: 132px) 100vw, 132px" />Caraval, Stephanie Garber</h2>
<p><strong>Why I don&#8217;t want to read it 🔎</strong> <em>Caraval</em> is another really hyped book and&#8230; well, I found it entertaining, but I wasn&#8217;t as obsessed with it as other readers were, so the <strong>sequels aren&#8217;t really on my radar</strong>.</p>
<p><a class="button" style="display:inline-block;padding:2px;border:0;border-radius:2px;font-weight:10%;letter-spacing:0;text-transform:lowercase;background:#25727B;color:#ffffff;" href="https://drizzleandhurricanebooks.com/2017/08/25/review-caraval-stephanie-garber/">📖 read my full review of caraval</a></p>
<p>&nbsp;</p>
<p style="text-align:center;"><img data-attachment-id="10514" data-permalink="https://drizzleandhurricanebooks.com/2019/04/07/how-i-became-obsessed-with-books/lets-chat/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/lets-chat.png" data-orig-size="791,633" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="let&#8217;s chat" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/lets-chat.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/lets-chat.png?w=750" class="aligncenter wp-image-10514 size-medium" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/lets-chat.png?w=300&#038;h=240" alt="" width="300" height="240" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/lets-chat.png?w=300&amp;h=240 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/lets-chat.png?w=600&amp;h=480 600w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/lets-chat.png?w=150&amp;h=120 150w" sizes="(max-width: 300px) 100vw, 300px" /><span style="font-size:19pt;">Did you read any of these series? Did you enjoy them? Do you want to read them?<br />
</span></p>
<p style="text-align:center;"><span style="font-size:19pt;">What are some of your favorite book series? Let me know in comments! </span><br />
<img data-attachment-id="10534" data-permalink="https://drizzleandhurricanebooks.com/about/disclaimers/with-love-marie/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/with-love-marie.png" data-orig-size="700,360" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="with love, marie" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/with-love-marie.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/with-love-marie.png?w=700" class="alignright wp-image-10534 size-medium" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/with-love-marie.png?w=300&#038;h=154" alt="" width="300" height="154" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/with-love-marie.png?w=300&amp;h=154 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/with-love-marie.png?w=600&amp;h=308 600w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/with-love-marie.png?w=150&amp;h=77 150w" sizes="(max-width: 300px) 100vw, 300px" /></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p style="text-align:right;"><em><a href="http://twitter.com/dh_books">Twitter</a> ☂️ <a href="https://www.goodreads.com/user/show/7534484-marie">Goodreads</a> ☂️ <a href="https://www.bloglovin.com/blogs/drizzle-hurricane-books-14107765">Bloglovin</a> &#8216;☂️ <a href="https://ko-fi.com/drizzleandhurricanebooks">Support the blog</a></em></p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Partager&nbsp;:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-13553" class="share-twitter sd-button share-icon" href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-13553" class="share-facebook sd-button share-icon" href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-79956226-13553-5e57abd981828' data-src='//widgets.wp.com/likes/index.html?ver=20190321#blog_id=79956226&amp;post_id=13553&amp;origin=drizzleandhurricanebooks.wordpress.com&amp;obj_id=79956226-13553-5e57abd981828&amp;domain=drizzleandhurricanebooks.com' data-name='like-post-frame-79956226-13553-5e57abd981828'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>	</div><!-- .entry-content -->

	<footer class="entry-footer">
							<div class="author-info">
				<div class="author-gravatar">
					<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=94&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-94' height='94' width='94' />				</div><!-- .author-gravatar -->
				<div class="author-description">
					<h3>Posted by <a href='https://drizzleandhurricanebooks.com/author/drizzleandhurricanebooks/' title='Marie' rel='author'>Marie</a></h3>
					<p>Book blogger, travel blogger, writer. 📚 |🌍 | 💞 
Writing &amp; Communications Graduate. French. 
Living on love, wanderlust and ya books.</p>
				</div><!-- .author-descriptio -->
			</div><!-- .author-info -->
			</footer><!-- .entry-footer -->
</article><!-- #post-## -->
						
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://drizzleandhurricanebooks.com/2020/02/21/review-the-stars-we-steal-alexa-donne/" rel="prev">Review: The Stars We Steal, Alexa&nbsp;Donne</a></div></div>
	</nav>
						
<div id="comments" class="comments-area">

			<h2 class="comments-title">
			20 thoughts on &ldquo;<span>20 book series I want to finish reading&#8230;. or&nbsp;not</span>&rdquo;		</h2>

		
		<ol class="comment-list">
					<li id="comment-74853" class="comment byuser comment-author-flowersinthebrain even thread-even depth-1 parent highlander-comment">
			<article id="div-comment-74853" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://1.gravatar.com/avatar/d03fe6c06a60936aafee9909fdc0c4c0?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://flowersinthebrain.wordpress.com' rel='external nofollow ugc' class='url'>flowersinthebrain</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74853">
							<time datetime="2020-02-26T14:09:08+01:00">
								26 February 2020 at 14 h 09 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Loved this!</p>
<p id="comment-like-74853" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74853&#038;_wpnonce=463341f3ca" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74853" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74853#respond' data-commentid="74853" data-postid="13553" data-belowelement="div-comment-74853" data-respondelement="respond" aria-label='Reply to flowersinthebrain'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74874" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74874" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74874">
							<time datetime="2020-02-26T18:59:48+01:00">
								26 February 2020 at 18 h 59 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Thank you! 🙂</p>
<p id="comment-like-74874" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74874&#038;_wpnonce=6c3f71afb1" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74874" class="comment-like-feedback">Like</span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74874#respond' data-commentid="74874" data-postid="13553" data-belowelement="div-comment-74874" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74854" class="comment byuser comment-author-peanutfreeisme even thread-odd thread-alt depth-1 parent highlander-comment">
			<article id="div-comment-74854" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/6ece9d1832d5c68e1674c1882e4a6bb2?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://nutfreenerd.wordpress.com' rel='external nofollow ugc' class='url'>Holly</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74854">
							<time datetime="2020-02-26T14:14:33+01:00">
								26 February 2020 at 14 h 14 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I&#8217;ve also given up on the Miss Peregrine books I think&#8211;they just weren&#8217;t really my cup of tea. I really want to read This Savage Song though! Great post 🙂</p>
<p id="comment-like-74854" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74854&#038;_wpnonce=131cc650ae" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74854" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74854#respond' data-commentid="74854" data-postid="13553" data-belowelement="div-comment-74854" data-respondelement="respond" aria-label='Reply to Holly'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74875" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74875" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74875">
							<time datetime="2020-02-26T19:08:37+01:00">
								26 February 2020 at 19 h 08 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I&#8217;m glad I&#8217;m not the only one! I felt a little bit disappointed by the first book, it made me so sad because I know a lot of people love this. But I guess it can&#8217;t be for everyone 🙂<br />
thank you so, so much Holly! ❤</p>
<p id="comment-like-74875" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74875&#038;_wpnonce=40754ddf8a" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74875" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74875#respond' data-commentid="74875" data-postid="13553" data-belowelement="div-comment-74875" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74855" class="comment byuser comment-author-santanareads even thread-even depth-1 parent highlander-comment">
			<article id="div-comment-74855" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://2.gravatar.com/avatar/ea2a2fee9430bdbff867ac116f9767bf?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://santanareads.wordpress.com' rel='external nofollow ugc' class='url'>Carolina V.</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74855">
							<time datetime="2020-02-26T14:15:20+01:00">
								26 February 2020 at 14 h 15 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I also absolutely loved This Mortal Coil when I read it! Someone was even kind enough to send an ARC the 2nd book in the series to me and I just&#8230;never got around to it 😔<br />
AHHH, SO EXCITED FOR WE UNLEASH THE MERCILESS STORM! I&#8217;l be rereading WSTDOF in March and can&#8217;t wait to experience that brilliance all over again 🥰</p>
<p id="comment-like-74855" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74855&#038;_wpnonce=88e92656d4" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74855" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74855#respond' data-commentid="74855" data-postid="13553" data-belowelement="div-comment-74855" data-respondelement="respond" aria-label='Reply to Carolina V.'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74876" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74876" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74876">
							<time datetime="2020-02-26T19:10:20+01:00">
								26 February 2020 at 19 h 10 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Aahh that&#8217;s amazing! I hope you can read This Cruel Design soon and will love it. I can&#8217;t wait to get a copy myself 😀<br />
AH YES I am just SO happy to find someone as excited as I am for We Unleash The Merciless Storm!! I&#8217;m waiting for my copy to arrive and I just can&#8217;t WAIT AHH. I&#8217;m so excited, the first book was so good! ❤<br />
Thank you so, so much for your sweet comment, Carolina ❤</p>
<p id="comment-like-74876" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74876&#038;_wpnonce=a23e4a99eb" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74876" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74876#respond' data-commentid="74876" data-postid="13553" data-belowelement="div-comment-74876" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74856" class="comment byuser comment-author-sofi022 even thread-odd thread-alt depth-1 parent highlander-comment">
			<article id="div-comment-74856" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/c5592b593b1daae0f46ebb67b5bdd76c?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://abookathoughtblog.wordpress.com' rel='external nofollow ugc' class='url'>Sofii @ A Book. A Thought.</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74856">
							<time datetime="2020-02-26T15:09:23+01:00">
								26 February 2020 at 15 h 09 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>An Ember in the Ashes series is absolutely amazing!! 😍 The author has just finished with the fourth book and although there isn&#8217;t even a release date, I CAN&#8217;T WAIT!  Each book is better than the previous one &amp; I really want to read Legend!!  Marie Lu hasn&#8217;t disappointed me so far and it sounds great! ❤️✨🥰</p>
<p id="comment-like-74856" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74856&#038;_wpnonce=6d6f984d94" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74856" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74856#respond' data-commentid="74856" data-postid="13553" data-belowelement="div-comment-74856" data-respondelement="respond" aria-label='Reply to Sofii @ A Book. A Thought.'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74877" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74877" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74877">
							<time datetime="2020-02-26T19:11:13+01:00">
								26 February 2020 at 19 h 11 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Ahh I agree, I loved the first two books so much, I am so nervous about A Reaper at the Gates ahah.<br />
I hope you&#8217;ll give Legend a try, I really enjoyed the first book and can&#8217;t wait to continue with it 🙂<br />
Thank you so, so much for your sweet comment Sofi! ❤</p>
<p id="comment-like-74877" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74877&#038;_wpnonce=5aca713271" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74877" class="comment-like-feedback">Like</span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74877#respond' data-commentid="74877" data-postid="13553" data-belowelement="div-comment-74877" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74857" class="comment byuser comment-author-booksteacupnreviews even thread-even depth-1 parent highlander-comment">
			<article id="div-comment-74857" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/6e9b845d23aa8b8f203951bcf26e747d?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://booksteacupnreviews.wordpress.com' rel='external nofollow ugc' class='url'>Books, Teacup, and Reviews</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74857">
							<time datetime="2020-02-26T15:37:52+01:00">
								26 February 2020 at 15 h 37 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I&#8217;m going to read children of virtue and vengeance. I read star touched queen. I agree second book is better than first.   I want finish Clifton Chronicles and have 3 Jenny Colgan&#8217;s series and many more to read. My fav completed series so far is Percy Jackson, mortal instruments, and Lunar Chronicle. Oh and Harry Potter</p>
<p id="comment-like-74857" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74857&#038;_wpnonce=e6aa956755" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74857" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74857#respond' data-commentid="74857" data-postid="13553" data-belowelement="div-comment-74857" data-respondelement="respond" aria-label='Reply to Books, Teacup, and Reviews'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74878" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74878" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74878">
							<time datetime="2020-02-26T19:11:53+01:00">
								26 February 2020 at 19 h 11 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>ahh I hope you&#8217;ll enjoy children of virtue and vengeance! 🙂<br />
AH YES the Lunar Chronicles is such a good series, I love it. and Harry Potter, too, obviously 😀</p>
<p id="comment-like-74878" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74878&#038;_wpnonce=9991dc5119" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74878" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74878#respond' data-commentid="74878" data-postid="13553" data-belowelement="div-comment-74878" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74858" class="comment byuser comment-author-jennanicolee even thread-odd thread-alt depth-1 parent highlander-comment">
			<article id="div-comment-74858" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://2.gravatar.com/avatar/28a4826842b44f811eea3d7b37c0f06f?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://bookmarkyourthoughts.blog' rel='external nofollow ugc' class='url'>Jenna @ Bookmark Your Thoughts</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74858">
							<time datetime="2020-02-26T15:55:36+01:00">
								26 February 2020 at 15 h 55 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>&#8220;Am I Normal Yet&#8221; is one I&#8217;ve had on my TBR list for WAY too long &#8212; I really need to read it this year. I got &#8220;Mirage&#8221; in an OwlCrate sometime ago and never read it &#8230; I don&#8217;t know if the series is completely out yet, so I was waiting on that (I think) ha-ha!</p>
<p>&#8220;Daughter of Smoke and Bone&#8221; is a book series that I&#8217;ve been CONTEMPLATING reading &#8212; but I don&#8217;t know yet. I&#8217;ve heard good things, but I just hate getting into a series that I&#8217;m later disappointed with lol!</p>
<p>I feel you with &#8220;The Cruel Prince&#8221; &#8230; I REALLY don&#8217;t know if I want to get into that series. Same with &#8220;Caraval&#8221; &#8212; because I want to love it but I don&#8217;t know if I will &#8230; I think I&#8217;ll end up reading &#8220;Caraval&#8221; though ha-ha!</p>
<p>Great post!</p>
<p id="comment-like-74858" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74858&#038;_wpnonce=4cf5b973f2" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74858" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74858#respond' data-commentid="74858" data-postid="13553" data-belowelement="div-comment-74858" data-respondelement="respond" aria-label='Reply to Jenna @ Bookmark Your Thoughts'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74879" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74879" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74879">
							<time datetime="2020-02-26T19:13:39+01:00">
								26 February 2020 at 19 h 13 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>AH YES JENNA! I hope you&#8217;ll read Am I Normal Yet soon, it&#8217;s such an underrated contemporary, I love it so much. ❤<br />
I think that Mirage is a duology, if I remember right? not sure though. I&#039;d be curious to hear your thoughts if you get around to it 😀 </p>
<p>I&#039;m glad I&#039;m not the only one a little on the fence about the cruel prince! it&#039;s so hyped, the first book was good, but I wasn&#039;t head over heels with it either. I might be missing out on something here hahaha.<br />
Thank you so, so much Jenna! ❤</p>
<p id="comment-like-74879" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74879&#038;_wpnonce=94275a0bf0" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74879" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74879#respond' data-commentid="74879" data-postid="13553" data-belowelement="div-comment-74879" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74859" class="comment byuser comment-author-evelynreads1 even thread-even depth-1 parent highlander-comment">
			<article id="div-comment-74859" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/0f5628212b4bb1a23fab7db90f5b2b8b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn">evelynreads1</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74859">
							<time datetime="2020-02-26T16:20:08+01:00">
								26 February 2020 at 16 h 20 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I really would like to read The reader series! It sounds good!<br />
I can&#8217;t wait for the sequel of The gilded wolves!</p>
<p>(www.evelynreads.com)</p>
<p id="comment-like-74859" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74859&#038;_wpnonce=6b3ef7fad0" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74859" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74859#respond' data-commentid="74859" data-postid="13553" data-belowelement="div-comment-74859" data-respondelement="respond" aria-label='Reply to evelynreads1'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74880" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74880" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74880">
							<time datetime="2020-02-26T19:14:01+01:00">
								26 February 2020 at 19 h 14 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>YES! I hope you&#8217;ll be able to read The Reader soon, I ADORE this series with all my heart ❤</p>
<p id="comment-like-74880" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74880&#038;_wpnonce=5ef6d99b33" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74880" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74880#respond' data-commentid="74880" data-postid="13553" data-belowelement="div-comment-74880" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74860" class="comment byuser comment-author-ajsterkel15 even thread-odd thread-alt depth-1 parent highlander-comment">
			<article id="div-comment-74860" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://2.gravatar.com/avatar/511cbbdee63cd1dfc6acbf51b7fb0787?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://ajsterkel.blogspot.com' rel='external nofollow ugc' class='url'>Aj @ Read All The Things!</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74860">
							<time datetime="2020-02-26T16:50:24+01:00">
								26 February 2020 at 16 h 50 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I quit almost every series I start. I think the books often go downhill after the first one, and then I get disappointed. That’s what happened with Daughter of Smoke and Bone. I LOVED the first one and considered DNFing the last one. I do want to try The Cruel Prince and An Ember in the Ashes. I want to know what the hype is about.</p>
<p id="comment-like-74860" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74860&#038;_wpnonce=5ec839228c" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74860" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74860#respond' data-commentid="74860" data-postid="13553" data-belowelement="div-comment-74860" data-respondelement="respond" aria-label='Reply to Aj @ Read All The Things!'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74881" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74881" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74881">
							<time datetime="2020-02-26T19:15:29+01:00">
								26 February 2020 at 19 h 15 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Oh I get that! I keep on procrastinating series for that reason as well, a little scared of being disappointed. Some series end up being good from beginning to end, it&#8217;s a chance we have to take 🙂<br />
I hope you&#8217;ll give both books a try, especially An Ember in the Ashes! I think this book really deserves its hype, it&#8217;s stunning!<br />
Thank you so, so much for your sweet comment ❤</p>
<p id="comment-like-74881" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74881&#038;_wpnonce=5f1210a0fb" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74881" class="comment-like-feedback">Like</span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74881#respond' data-commentid="74881" data-postid="13553" data-belowelement="div-comment-74881" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74861" class="comment byuser comment-author-anovelglimpse even thread-even depth-1 parent highlander-comment">
			<article id="div-comment-74861" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/cb5cef424629e80e0344caf2ee12c8ac?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://anovelglimpse.wordpress.com' rel='external nofollow ugc' class='url'>anovelglimpse</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74861">
							<time datetime="2020-02-26T17:21:14+01:00">
								26 February 2020 at 17 h 21 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>I didn&#8217;t read past Daughter of Smoke &amp; Bone either. That twist was just a turn off for me.</p>
<p id="comment-like-74861" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74861&#038;_wpnonce=0e6448407b" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74861" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74861#respond' data-commentid="74861" data-postid="13553" data-belowelement="div-comment-74861" data-respondelement="respond" aria-label='Reply to anovelglimpse'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74882" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74882" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74882">
							<time datetime="2020-02-26T19:15:52+01:00">
								26 February 2020 at 19 h 15 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>ohhhh I can understand that, I was a bit thrown off by this too!</p>
<p id="comment-like-74882" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74882&#038;_wpnonce=68b69e8e82" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74882" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74882#respond' data-commentid="74882" data-postid="13553" data-belowelement="div-comment-74882" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-74864" class="comment byuser comment-author-melinaelisa even thread-odd thread-alt depth-1 parent highlander-comment">
			<article id="div-comment-74864" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://1.gravatar.com/avatar/db882560ea775869aba9c6a8881a35b3?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='http://www.melinaelisa.com' rel='external nofollow ugc' class='url'>Melina Elisa</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74864">
							<time datetime="2020-02-26T17:58:28+01:00">
								26 February 2020 at 17 h 58 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>the only book series in this series that I have started to read and not finish is the uglies series! I got through the first book, loved it, and never bought the second one. A book series that I have yet to finish was the vampire academy series. I was obsessed. It was finals week in college, and instead of spending my time studying I finished 5 of the books. It was terribleeee. I was so obsessed. When I finally finished the 5th book, I didn&#8217;t pick up the 6th one and actually studied. The crazy part was that I never ended up picking up the book again! I still am yet to finish the series and it&#8217;s been at least 3 years! Great post Marie xxx</p>
<p>Melina | <a href="http://www.melinaelisa.com" rel="nofollow ugc">http://www.melinaelisa.com</a></p>
<p id="comment-like-74864" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74864&#038;_wpnonce=177fc39e81" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74864" class="comment-like-feedback">Liked by <a href="#" class="view-likers" data-like-count="1">1 person</a></span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74864#respond' data-commentid="74864" data-postid="13553" data-belowelement="div-comment-74864" data-respondelement="respond" aria-label='Reply to Melina Elisa'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-74885" class="comment byuser comment-author-drizzleandhurricanebooks bypostauthor odd alt depth-2 highlander-comment">
			<article id="div-comment-74885" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://0.gravatar.com/avatar/04d3cd75f4f7a16d0c03ddf2d5ad875b?s=74&#038;d=https%3A%2F%2Fs0.wp.com%2Fi%2Fmu.gif&#038;r=G' class='avatar avatar-74' height='74' width='74' />						<b class="fn"><a href='https://drizzleandhurricanebooks.wordpress.com' rel='external nofollow ugc' class='url'>Marie</a></b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#comment-74885">
							<time datetime="2020-02-26T19:19:29+01:00">
								26 February 2020 at 19 h 19 min							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>aahh MELINA! I&#8217;m going to scream at you to read the Uglies series now 😂 it&#8217;s one of my favorites ever, for sure, I hope you&#8217;ll feel like reading more of it someday 😀<br />
OH Yes this happens to me too sometimes! I start a series and get obsessed with it, then something comes up and I never finish it. It&#8217;s a little frustrating ahah.<br />
Thank you so, so much!! xx</p>
<p id="comment-like-74885" data-liked=comment-not-liked class="comment-likes comment-not-liked"><a href="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?like_comment=74885&#038;_wpnonce=da6002b52c" class="comment-like-link needs-login" rel="nofollow" data-blog="79956226"><span>Like</span></a><span id="comment-like-count-74885" class="comment-like-feedback">Like</span></p>
				</div><!-- .comment-content -->

				<div class="reply"><a rel='nofollow' class='comment-reply-link' href='https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/?replytocom=74885#respond' data-commentid="74885" data-postid="13553" data-belowelement="div-comment-74885" data-respondelement="respond" aria-label='Reply to Marie'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://drizzleandhurricanebooks.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="482aa8d9ff" /><input type="hidden" name="_wp_http_referer" value="/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://s0.wp.com/i/mu.gif" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://s0.wp.com/i/mu.gif" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://s0.wp.com/i/mu.gif" alt="Google photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://s0.wp.com/i/mu.gif" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://s0.wp.com/i/mu.gif" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='13553' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2ff941bced" /></p>
<input type="hidden" name="genseq" value="1582803929" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="212"/></p></form>	</div><!-- #respond -->
	<div style="clear: both"></div><p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!-- #comments -->

					
				</main><!-- #main -->
			</div><!-- #primary -->
			
<aside id="secondary" class="widget-area col-lg-offset-1 col-lg-3" role="complementary">
		<section id="media_image-4" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img width="1000" height="1000" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png?w=1000" class="image wp-image-10503  attachment-1000x1000 size-1000x1000" alt="" style="max-width: 100%; height: auto;" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png 1000w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png?w=150 150w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png?w=300 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png?w=768 768w" sizes="(max-width: 1000px) 100vw, 1000px" data-attachment-id="10503" data-permalink="https://drizzleandhurricanebooks.com/welcome-to-my-blog/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png" data-orig-size="1000,1000" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="welcome to my blog" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/welcome-to-my-blog.png?w=750" /></section><section id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><p style="text-align:center;">
<img src="https://i.imgur.com/eOHecte.jpg" width="220" height="220">
</p>

<p style="text-align:justify;">
I'm Marie, a 20-something book blogger. Passions include young adult books, travelling, writing and chocolate. Thank you so much for stopping by! </p>

<p style="text-align:center;">
	<a class="button" style="display:inline-block;padding:5px;border:0;border-radius:5px;font-weight:10%;letter-spacing:0;text-transform:UPPERCASE;background:#25727B;color:#FFFFFF;" href="http://www.drizzleandhurricanebooks.com/about">ABOUT</a> <a class="button" style="display:inline-block;padding:5px;border:0;border-radius:5px;font-weight:10%;letter-spacing:0;text-transform:UPPERCASE;background:#25727B;color:#FFFFFF;" href="https://drizzleandhurricanebooks.com/about/work-with-me/">WORK WITH US</a></p>
<p style="text-align:center;">
	<a href="http://twitter.com/dh_books" title="twitter">
	<img alt="twitter" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/twitter.png" width="50" height="50" />
</a>
	<a href="https://www.goodreads.com/user/show/7534484-marie" title="goodreads">
	<img alt="goodreads" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/goodreads.png" width="50" height="50" />
</a> <a href="https://www.bloglovin.com/blogs/drizzle-hurricane-books-14107765" title="bloglovin">
	<img alt="bloglovin" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/bloglovin.png" width="50" height="50" />
</a>
	<a href="http://instagram.com/slowlyallatonce" title="instagram">
	<img alt="instagram" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/instagram.png" width="50" height="50" />
</a>
</p></div></section><section id="media_image-5" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img width="800" height="350" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png?w=800" class="image wp-image-10505  attachment-800x350 size-800x350" alt="" style="max-width: 100%; height: auto;" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png 800w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png?w=150 150w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png?w=300 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png?w=768 768w" sizes="(max-width: 800px) 100vw, 800px" data-attachment-id="10505" data-permalink="https://drizzleandhurricanebooks.com/support-the-blog/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png" data-orig-size="800,350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="support the blog" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/support-the-blog.png?w=750" /></section><section id="blog_subscription-2" class="widget widget_blog_subscription jetpack_subscription_widget">            <form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8"
                  id="subscribe-blog">
									<p>Join 10,154 other followers</p>
                    <p><input type="text" name="email" style="width: 95%; padding: 1px 2px"
                              placeholder="Enter your email address" value=""
                              id="subscribe-field"/></p>
				
                <p>
                    <input type="hidden" name="action" value="subscribe"/>
                    <input type="hidden" name="blog_id" value="79956226"/>
                    <input type="hidden" name="source" value="https://drizzleandhurricanebooks.com/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/"/>
                    <input type="hidden" name="sub-type" value="widget"/>
                    <input type="hidden" name="redirect_fragment" value="blog_subscription-2"/>
					<input type="hidden" id="_wpnonce" name="_wpnonce" value="3536a69bf4" />                    <button type="submit"
	                    		                	                >
	                    Follow                    </button>
                </p>
            </form>
			
</section><section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<p style="text-align:center;"><a href='https://ko-fi.com/K3K6GJMW' target='_blank' rel="noopener noreferrer"><img height='36' style='border:0;height:36px;' src='https://az743702.vo.msecnd.net/cdn/kofi2.png?v=0' border='0' alt='Buy Me a Coffee at ko-fi.com' /></a></p></div></section><section id="search-4" class="widget widget_search">	<form method="get" id="searchform" action="https://drizzleandhurricanebooks.com/">
		<label for="s" class="screen-reader-text"><span>Search</span></label>
		<input type="text" class="field" name="s" id="s" autocomplete="off" />
		<button type="submit" class="submit" name="submit" id="searchsubmit"><span class="screen-out-text">Search</span></button>
	</form>
</section><section id="media_image-8" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img width="800" height="350" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png?w=800" class="image wp-image-10508  attachment-800x350 size-800x350" alt="" style="max-width: 100%; height: auto;" srcset="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png 800w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png?w=150 150w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png?w=300 300w, https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png?w=768 768w" sizes="(max-width: 800px) 100vw, 800px" data-attachment-id="10508" data-permalink="https://drizzleandhurricanebooks.com/currently-reading/" data-orig-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png" data-orig-size="800,350" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="currently reading" data-image-description="" data-medium-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png?w=300" data-large-file="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/currently-reading.png?w=750" /></section><section id="wpcom-goodreads-2" class="widget widget_goodreads"><h2 class="widget-title">Goodreads</h2><div class="gr_custom_widget" id="gr_custom_widget_7534484_currently-reading"></div>
<script src="https://www.goodreads.com/review/custom_widget/7534484.:%20currently-reading?cover_position=&#038;cover_size=small&#038;num_books=5&#038;order=d&#038;shelf=currently-reading&#038;sort=date_added&#038;widget_bg_transparent=&#038;widget_id=7534484_currently-reading"></script>
</section><section id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">	<img alt="button" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/03/grab-my-button.png" width="300" height="131" />
	
<a href="http://www.drizzleandhurricanebooks.com" title="button">
	<img alt="button" src="https://drizzleandhurricanebooks.files.wordpress.com/2019/01/drizzle-and-hurricane-books-button-3.png" width="350" height="350" />
</a></div></section></aside><!-- #secondary -->
		</div><!-- .row -->
	</div><!-- .container -->
</section><!-- #main -->


		<footer id="colophon" class="site-footer" role="contentinfo">
						<section id="full-footer">
				
<aside id="footerfull" class="widget-area" role="complementary">
	<section id="wpcom_instagram_widget-3" class="widget widget_wpcom_instagram_widget"><div class="wpcom-instagram-images wpcom-instagram-columns-1">
<a href="https://www.instagram.com/p/B88xppCoOfOUDolk29i89vFIdcsoqUKsy2umb40/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/v/t51.2885-15/sh0.08/e35/s640x640/87232715_180734420022361_7459670907945689241_n.jpg?_nc_ht=scontent.cdninstagram.com&#038;_nc_ohc=l7OxAsfUI-EAX_8WB5J&#038;oh=2ec5d6ae061001df5e337ff08c601de0&#038;oe=5E83F3B5)"><span class="screen-reader-text">Lunch time 🥞 
#foodporn #pancakes #salmon #strasbourg #france</span></div></a>
<a href="https://www.instagram.com/p/B86H1w4IoSIiLlWJTQvqZ4fIAB_r8N44pSSCkc0/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/v/t51.2885-15/sh0.08/e35/s640x640/84024514_184253979562896_5673857940693790424_n.jpg?_nc_ht=scontent.cdninstagram.com&#038;_nc_ohc=NVFgoovi9VYAX_ReRHm&#038;oh=829bb50a7314af647515cc1687df40a3&#038;oe=5E83414E)"><span class="screen-reader-text">Wandering in Paris ☁️ #paris #weekend #france #travelgram #travel #pontdesarts</span></div></a>
<a href="https://www.instagram.com/p/B84wt7KIDFDgSbPB1TltMJXnllR8xL1n-h5tZA0/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/v/t51.2885-15/sh0.08/e35/s640x640/84326487_135207634425388_1676158835292929203_n.jpg?_nc_ht=scontent.cdninstagram.com&#038;_nc_ohc=EQ9C84F7qjwAX9ew-hh&#038;oh=81980d68509d2e9bf40f25e11fdac2ab&#038;oe=5E8728F1)"><span class="screen-reader-text">Here 10 years ago, here today, here always ✨❤️ #jonasbrothers #accorhotelsarena #paris #bercy #concert</span></div></a>
<a href="https://www.instagram.com/p/B830VvZIwuC_UBqribiJo57xlalZxhezo6MH6k0/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/v/t51.2885-15/sh0.08/e35/s640x640/85175460_192174085467374_3233851782092387489_n.jpg?_nc_ht=scontent.cdninstagram.com&#038;_nc_ohc=whZRfj4MU5oAX-W3_Af&#038;oh=4db8b292d3bca8b8bafae3ac74143086&#038;oe=5E83D054)"><span class="screen-reader-text">Parisian weekend ✨ 
#travel #travelgram #paris #france #arcdetriomphe #weekend #nofilter</span></div></a>
<a href="https://www.instagram.com/p/B6xkIp2o1rfXThxmujOVEoNxsyY_QZS7qas3j00/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/v/t51.2885-15/sh0.08/e35/s640x640/79793151_566979190515877_4792528171614508690_n.jpg?_nc_ht=scontent.cdninstagram.com&#038;_nc_ohc=iR67GOrAH0EAX9qtx3y&#038;oh=6fa4691a900d1bd339973185d6ecea01&#038;oe=5E8B4700)"><span class="screen-reader-text">Snapshot of 2019. Home, England, Croatia, Canada. Here’s to more adventures in 2020 ❤️✨ Happy New Year, friends 🎉 
#bestnine2019 #travel #travelgram #london #alsace #croatia #canada #niagarafalls #home</span></div></a>
<a href="https://www.instagram.com/p/B6s0IAiIIXAaq9GONG_H1wQiWXQED4bISB2XjU0/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/v/t51.2885-15/sh0.08/e35/s640x640/79600571_2506204279488603_3443437178827614081_n.jpg?_nc_ht=scontent.cdninstagram.com&#038;_nc_ohc=Qg7_dRVmOHkAX8ebAaf&#038;oh=1f6ec42831d7d776edd66f60352e5b9c&#038;oe=5E87DE08)"><span class="screen-reader-text">You’re still pretty, Lille ❤️✨
#lille #france #travel #travelgram #love</span></div></a>
<a href="https://www.instagram.com/p/B5z-rzSIE6Pokxrq0V3LbD19vm7yLaA_3saZ0Y0/" target="_self"><div class="sq-bg-image" style="background-image: url(https://scontent.cdninstagram.com/v/t51.2885-15/sh0.08/e35/s640x640/74804485_470120086978348_7851373472656628896_n.jpg?_nc_ht=scontent.cdninstagram.com&#038;_nc_ohc=4cL58ae28tUAX-bTskl&#038;oh=65ef1dc6ce18c26b18c30b98e6c46aea&#038;oe=5E8CBDF3)"><span class="screen-reader-text">Christmas season 🏘🎄
#alsace #france #home #christmas #weekend</span></div></a>
</div>
</section></aside><!-- #footerinstagram -->
			</section><!-- #instagram-footer -->
									<section id="pre-footer" class="pre-footer">
				<div class="container">
					<div class="row">
																			<div class="textcenter-xs social-footer">
															</div><!-- .social-footer -->
											</div><!-- .row -->
				</div><!-- .container -->
			</section><!-- #main -->
						<div class="site-info">
				<div class="container">
					<div class="row">
						<div class="col-md-12">
							<p class="info textcenter-xs">
								<a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a>
								
															</p>
						</div><!-- .col-md-12 -->
					</div><!-- .row -->
				</div><!-- .contaniner -->
			</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #page -->

	<!--  -->
<script src='//0.gravatar.com/js/gprofiles.js?ver=202009y'></script>
<script>
var WPGroHo = {"my_hash":""};
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	<div class="grofile-hash-map-04d3cd75f4f7a16d0c03ddf2d5ad875b">
	</div>
	<div class="grofile-hash-map-d03fe6c06a60936aafee9909fdc0c4c0">
	</div>
	<div class="grofile-hash-map-04d3cd75f4f7a16d0c03ddf2d5ad875b">
	</div>
	<div class="grofile-hash-map-6ece9d1832d5c68e1674c1882e4a6bb2">
	</div>
	<div class="grofile-hash-map-ea2a2fee9430bdbff867ac116f9767bf">
	</div>
	<div class="grofile-hash-map-c5592b593b1daae0f46ebb67b5bdd76c">
	</div>
	<div class="grofile-hash-map-6e9b845d23aa8b8f203951bcf26e747d">
	</div>
	<div class="grofile-hash-map-28a4826842b44f811eea3d7b37c0f06f">
	</div>
	<div class="grofile-hash-map-0f5628212b4bb1a23fab7db90f5b2b8b">
	</div>
	<div class="grofile-hash-map-511cbbdee63cd1dfc6acbf51b7fb0787">
	</div>
	<div class="grofile-hash-map-cb5cef424629e80e0344caf2ee12c8ac">
	</div>
	<div class="grofile-hash-map-db882560ea775869aba9c6a8881a35b3">
	</div>
	</div>
<script>
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/drizzleandhurricanebooks.wordpress.com\/public.api\/connect\/?action=request&domain=drizzleandhurricanebooks.com","logoutURL":"https:\/\/drizzleandhurricanebooks.wordpress.com\/wp-login.php?action=logout&_wpnonce=387ca88aed","homeURL":"https:\/\/drizzleandhurricanebooks.com\/","postID":"13553","gravDefault":"blank","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1573483029j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="79956226" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://drizzleandhurricanebooks.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="e26a899f0a" /><input type="hidden" name="_wp_http_referer" value="/2020/02/26/20-book-series-i-want-to-finish-reading-or-not/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/drizzleandhurricanebooks.com\/2020\/02\/26\/20-book-series-i-want-to-finish-reading-or-not\/":13553};
	</script>
				<link rel='stylesheet' id='all-css-0-3' href='https://s2.wp.com/_static/??/wp-content/plugins/gutenberg-blocks/jetpack-layout-grid/blocks/front.css,/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1576278967j&cssminify=yes' type='text/css' media='all' />
<script>
var comment_like_text = {"loading":"Loading..."};
</script>
<script>
var actionbardata = {"siteID":"79956226","siteName":"drizzleandhurricanebooks.com","siteURL":"https:\/\/drizzleandhurricanebooks.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/9a7bb0dd9e189b707244722c0b94bc8e?s=50&d=https%3A%2F%2Fs2.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"premium\/rosalie","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fdrizzleandhurricanebooks.com%2F2020%2F02%2F26%2F20-book-series-i-want-to-finish-reading-or-not%2F&signup_flow=account&domain=drizzleandhurricanebooks.com","themeURL":"https:\/\/wordpress.com\/theme\/rosalie\/","xhrURL":"https:\/\/drizzleandhurricanebooks.com\/wp-admin\/admin-ajax.php","nonce":"7f8a3150d5","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"3536a69bf4\" \/>","referer":"https:\/\/drizzleandhurricanebooks.com\/2020\/02\/26\/20-book-series-i-want-to-finish-reading-or-not\/","canFollow":"1","feedID":"60519877","statusMessage":"","customizeLink":"https:\/\/drizzleandhurricanebooks.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fdrizzleandhurricanebooks.wordpress.com%2F2020%2F02%2F26%2F20-book-series-i-want-to-finish-reading-or-not%2F","postID":"13553","shortlink":"https:\/\/wp.me\/p5pugy-3wB","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/drizzleandhurricanebooks.com\/13553","statsLink":"https:\/\/wordpress.com\/stats\/post\/13553\/drizzleandhurricanebooks.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Rosalie","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/read\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 10,154 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fdrizzleandhurricanebooks.com%2F2020%2F02%2F26%2F20-book-series-i-want-to-finish-reading-or-not%2F&signup_flow=account&domain=drizzleandhurricanebooks.com\">Log in now.<\/a>","stats":"Stats"}};
</script>
<script>
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/drizzleandhurricanebooks.com\/wp-admin\/admin-ajax.php","nonce":"c14ef91408","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/drizzleandhurricanebooks.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fdrizzleandhurricanebooks.com%2F2020%2F02%2F26%2F20-book-series-i-want-to-finish-reading-or-not%2F","blog_id":"79956226","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=79956226&v=wpcom&tz=1&user_id=0&subd=drizzleandhurricanebooks","is_public":"1","reblog_enabled":""};
</script>
<script>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVUltygzAMvFAdJ0Ag+ej0KB1jZCLwq35Ac/uaBjJpSpnpl2VJu9JKoqMl3OgAOtDO0wYG5GA/d51/oQ8hFYmVsUXtqcQePP2IEOHCdCPBLcmouYxNCk5E6AMdQDfGTSFr5FWglDuF+pl7IRZRSuIxAIEGA+p2LknL/FiVp6osai5EdqqY4AfIm30BJRSiyhkU++ycl7SWJoGMD54kk/dzFwjjhh5ulEouctPVTQJr6ke08B/QD8dfCtuYvjW49tZeAkKwjPcEhgnLTdShMaOmc/jJvTbnpa4DK69r0w0XUCnVOlAYFXXGM4kwQUXUPKDRv9p90MmaRElq5qhiPoBLFjEDOIdT/bvvnwzBJdGbZb8bm0B3a028t7g6lC5dp7vOz+4xa22VzJnoQd6XsTi2+uvRKwgk3+3pe6pMhXFqI3+6SSIkQ0f9hbl028ubQG/q9XA8ZVVWZPm5+wK26FMK'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://s0.wp.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?m=1573572739h&#038;ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?m=1540208548h&#038;ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://s1.wp.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?m=1550600082h&#038;ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://s2.wp.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?m=1540208548h&#038;ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20190321#ver=20190321' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?60" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'79956226','blog_tz':'1','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'79956226','v':'wpcom','tz':'1','user_id':'0','post':'13553','subd':'drizzleandhurricanebooks'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5U1JMLU8/MkNtblkvY1dMeDhFKyVaPzFCUj9bd3hNMlFQWzFGOVJ+bDZ+akRsWTBPMWU4K35pbDZdW11oeEJ2fCxfV1lOYmtaVXFOQ344LEgyQmdMdjdOQThqOTQ0NWdKZ2N1LkFQLV1hR0h4ZX5qeWFHN1tQa2xBOWpdfkx3QjBpZ2RTYzUlazF1VnIwMGdJRlFFME1kMlZNL24wfFNCOH58MU15R3xSNz9femQ3X0VQREIvcT9oK0l2OFhRbCVvQWtRdkJ2XXk5eStKMTkuRSx8Zz9PMmlXMn5kalFiNiVOWiV2aXoxSHFQdUh5dkdlaV9WTg=='}]);
_stq.push([ 'clickTrackerInit', '79956226', '13553' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated in 0.216 seconds
	194026 bytes batcached for 300 seconds
-->
